Open tracking metrics delay
Incident Report for FeedBlitz
Resolved
All the metrics are now up to date.
Posted Jun 24, 2022 - 20:49 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 24, 2022 - 15:54 EDT
Monitoring
Some lists open tracking data has been very slow to populate. The cause has been identified and the data is being updated.
Posted Jun 24, 2022 - 15:54 EDT
This incident affected: Email Marketing.