SSL Certificate Expired
Incident Report for FeedBlitz
Resolved
The www and developer sites have been updated, all interactions should now behave as expected. If not, force a refresh (Shift F5, typically) to reload the page
Posted Aug 20, 2021 - 17:23 EDT
Monitoring
App-based certificates are now working, www and developer sites will be addressed shortly.
Posted Aug 20, 2021 - 11:14 EDT
Identified
The certificate is being renewed. We apologize for the disruption,
Posted Aug 20, 2021 - 09:03 EDT
This incident affected: Email Marketing, RSS feeds, Management Portal, and Forms and Landing Pages.