System-wide outage

Incident Report for FeedBlitz

Resolved

FeedBlitz is now running as expected. We apologize for the inconvenience this Christmas morning!

If a mailing did not go out as expected, or did not reach the expected audience, you may log in, go to the relevant list's dashboard, and use the edit & resend / clone functions to (re)send the email to anyone who did not receive it at first.

The root cause of the incident was an initial failure of a system, which correctly failed over to its backup. However, that backup also failed approximately an hour later. We are reviewing why that happened, and how to make the service more resilient to multiple devops issues in teh future.
Posted Dec 25, 2025 - 09:54 EST

Monitoring

Services are now restored to full capacity. We are now working on sendng out any mailings that were missed during the outage
Posted Dec 25, 2025 - 09:00 EST

Identified

FeedBlitz is now working albeit slowly. We're now working on restoring full performance and identifying any missed mailings
Posted Dec 25, 2025 - 08:25 EST

Investigating

At approximately 4:30am this morning two core elements of FeedBlitz failed. We are currently working on restoring the service
Posted Dec 25, 2025 - 08:20 EST
This incident affected: Email Marketing, RSS feeds, Management Portal, and Forms and Landing Pages.