www.feedblitz.com is unavailable - app services are running OK.
Incident Report for FeedBlitz
Resolved
The www server's connection to the Internet has been stable for some time.
Posted Mar 11, 2022 - 21:18 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 11, 2022 - 18:27 EST
Identified
Unfortunately the marketing web site's hosts are having a bad afternoon and www.feedblitz.com is down. Meanwhile, all our services are functioning 100% at app.feedblitz.com/f?Sites
Posted Mar 11, 2022 - 18:27 EST
Monitoring
The marketing web site - www.feedblitz.com - is now up and running again. We're monitoring it to validate it's stable.
Posted Mar 11, 2022 - 17:49 EST
Identified
FeedBlitz's marketing web site - www.feedblitz.com - is currently down. We're working with our hosting service to get it back ASAP, however the FeedBlitz app (email, RSS feeds, management portals) is working 100%. If you use the www site to log in, you can get to the app directly via https://app.feedblitz.com/f/?Sites
Posted Mar 11, 2022 - 17:45 EST