Availability and performance issues
Incident Report for FeedBlitz
Resolved
The incident has been resolved and affected mailings completed
Posted Jan 13, 2023 - 10:05 EST
Monitoring
The issue has been addressed and queued mailings are now being sent out. We're tracking performance to ensure it stays at expected levels, and will resolve this incident when all are done.
Posted Jan 13, 2023 - 09:37 EST
Identified
The issue has been identified. Outbound mailings will be delayed while measures are taken to address the issue.
Posted Jan 13, 2023 - 07:58 EST
Investigating
Elements of FeedBlitz are currently unavailable; engineers are working to identify and address the problem.
Posted Jan 13, 2023 - 07:31 EST
This incident affected: Email Marketing and Management Portal.