Very slow mailings, evening of 2023-04-26
Incident Report for FeedBlitz
Resolved
All pending mailings from earlier this evening have been successfully sent, and FeedBlitz is currently sending all mail as expected. We apologize for any inconvenience the slow sending this evening may have caused you.
Posted Apr 26, 2023 - 22:18 EDT
Identified
The issue has been identified and the system catching up. Mailings will processed in the order they were scheduled in
Posted Apr 26, 2023 - 20:09 EDT
This incident affected: Email Marketing.