Some slow mailings, 2022-05-11
Incident Report for FeedBlitz
Resolved
All pending mailings have completed and the system is performing nominally.
Posted May 11, 2022 - 14:15 EDT
Monitoring
Some large single mailings were taking significantly longer to complete than expected today. We have determined the cause of the problem, which has been addressed. Mailings are now catching up, and we expect them to complete by 2:15pm US EDT.
Posted May 11, 2022 - 13:35 EDT
This incident affected: Email Marketing.