Slow mailings

Incident Report for FeedBlitz

Resolved

This incident has been resolved.
Posted Mar 04, 2022 - 11:46 EST

Monitoring

We are monitoring system performance after the incident.
Posted Mar 04, 2022 - 11:24 EST

Identified

The problem has been identified. All delayed mailings are caught up, and current mailings are are working as normal.
Posted Mar 04, 2022 - 11:24 EST

Investigating

We are currently investigating this issue.
Posted Mar 04, 2022 - 07:54 EST
This incident affected: Email Marketing.