Delayed mailings and slow app response
Incident Report for FeedBlitz
Resolved
All sluggish overnight mailings have completed. We apologize for the inconvenience and frustrations that mailing delays can cause, and are working hard on eliminating the issue in the future as job #1
Posted Nov 03, 2023 - 13:52 EDT
Monitoring
Most mailings that were delayed have now completed, the remaining mailings are finishing up. We are continuing to monitor the remaining mailings
Posted Nov 03, 2023 - 12:38 EDT
Identified
The issue has been identified and mailings are now catching up and the app availability is improved. We appreciate your patience as we work to get your mailings out.
Posted Nov 03, 2023 - 11:31 EDT
Investigating
We are currently investigating this issue.
Posted Nov 03, 2023 - 08:52 EDT
This incident affected: Email Marketing and Management Portal.