Engagement data missing from UI and reports

Incident Report for FeedBlitz

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 22:33 EDT

Monitoring

We're making steady progress here and are 82% complete, but that does shift the ETA for completion to Monday
Posted Mar 08, 2026 - 22:17 EDT

Identified

Historic engagement data is currently no available in the reporting UI. The resolution is in progress and we expect to have it wrapped up on Sunday
Posted Mar 07, 2026 - 16:30 EST
This incident affected: Management Portal.