Click through failures and console

Incident Report for FeedBlitz

Resolved

The disruption to mailings and the console were resolved overnight. A new incident will be opened as teams wrap up work on historic data
Posted Mar 07, 2026 - 16:29 EST

Monitoring

the app is now up and running. Engagement reports are however incomplete; these will be addressed over the coming days.
Posted Mar 06, 2026 - 20:40 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 06, 2026 - 17:22 EST

Identified

Unfortunately recovery seems further away than expected based on earlier estimates. Our teams continue to work the issue
Posted Mar 06, 2026 - 17:22 EST

Monitoring

Starting around 4pm today, a core server and its backup experienced an overload, causing some services to be unavailable. we have identified the problem and are restoring capabilities
Posted Mar 06, 2026 - 16:37 EST
This incident affected: Email Marketing and Management Portal.