The overnight issue of broken links was mitigated mid morning US eastern time for those RSS to Email clients affected. While that mitigation was being worked, we held back mailings to ensure that future deliveries would work correctly.
When they were released to run full throttle, two consequential issues emerged that caused the FeedBlitz app to continue to deliver less than satisfactory performance:
- The very large jump in short term workload strained the infrastructure, causing app performance issues - A significant number of the emails bounced out as a result.
While both issues have been managed and the service is now running as expected, we do acknowledge that this was not the level of performance our clients expect from us. FeedBlitz will ensure that recipients who are flagged as bounced because of these issues will not be dropped from your lists. Meanwhile, any client can send a follow-up (via edit and resend) to subscribers who were sent but did not open your original email - please contact tech support if you need guidance on how to do this.
Posted Sep 11, 2025 - 18:28 EDT
Update
Backed up mailings have been generated and our servers our getting the backlog out as fast as they can. We apologize for the late deliveries and thank you for your patience while we continue to work to get the system up to speed
Posted Sep 11, 2025 - 14:14 EDT
Identified
Affected links will now go to the site's home page. Mailings are resuming