Scheduled mailings are delayed

Incident Report for FeedBlitz

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 05:54 EDT

Monitoring

The issue has been identified and a correction put in place. Scheduled broadcast mailings are now catching up; we apologize for the inconvenience.

RSS powered mailing were unaffected by this issue.
Posted Jun 11, 2025 - 20:26 EDT

Investigating

We are currently investigating this issue.
Posted Jun 11, 2025 - 19:54 EDT
This incident affected: Email Marketing.