www.feedblitz.com is down - use app.feedblitz.com to access your FeedBlitz services

Incident Report for FeedBlitz

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 11:31 EDT

Monitoring

The www site is up and running, however the change may take up to 24 hours to roll out to you.
Posted Sep 19, 2025 - 10:26 EDT

Identified

Our hosts are working on restoring the site. It being down doesn't affect mailings or RSS feed serving or tracking, the FeedBlitz service is 100% up.
Posted Sep 19, 2025 - 09:51 EDT
This incident affected: Management Portal.