Service disruption

Incident Report for FeedBlitz

Resolved

The issue with FeedBlitz systems caused by a storage malfunction last week has been resolved. Unfortunately, recovery of engagement data from the afternoon of Feb 6 and most of Feb 7 has only been partial as some raw data was lost during outage. We regret and apologize for any inconvenience this may cause.

Going forward we are changing our logging policies to allow for more robust data recovery, and performing an in-depth technical review to avoid the risk of this kind of incident recurring.
Posted Feb 12, 2025 - 09:45 EST

Update

The system is now fully functional apart from per-user engagement data. We will keep this incident open until all elements of FeedBlitz are at 100%
Posted Feb 06, 2025 - 18:05 EST

Update

FeedBlitz is still recovering from yesterday's tech issue, and is functioning in a degraded capacity. We apologize for the inconvenience while our teams continue to work to restore full functionality.
Posted Feb 06, 2025 - 08:27 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 18:15 EST

Identified

For some time this afternoon a technical issue as affected the availability of the app, engagement metrics, and scheduled mailings. The team is aware of the issue and is working to restore services as quickly as they can.
Posted Feb 05, 2025 - 16:58 EST
This incident affected: Email Marketing and Management Portal.