Currently unable to send emails and track engagement

Incident Report for FeedBlitz

Resolved

Mailings are being sent and engagement being recorded. Historical data and other issues related to this incident will be tracked separately.
Posted Mar 12, 2026 - 00:28 EDT

Investigating

We are currently investigating this issue.
Posted Mar 11, 2026 - 14:57 EDT
This incident affected: Email Marketing.