www.feedblitz.com is unavailable, but app.feedblitz.com is working fine
Incident Report for FeedBlitz
Resolved
Our host has brought www.feedblitz.com back online. Emails and feeds were not affected by this incident.
Posted Apr 01, 2023 - 05:55 EDT
Investigating
The issue is being researched by our hosts, log in to the app to send emails via https://app.feedblitz.com
Posted Apr 01, 2023 - 05:53 EDT