Investigating service availability and web site performance
Incident Report for FeedBlitz
Resolved
The incident has been resolved and all capabilities are running at 100%.
Posted Jun 25, 2021 - 22:08 EDT
Monitoring
We are now monitoring the service to ensure its continued return to normal.
Posted Jun 25, 2021 - 21:58 EDT
Update
The issue has been identified and services are returning to normal
Posted Jun 25, 2021 - 21:56 EDT
Investigating
We are currently investigating this issue.
Posted Jun 25, 2021 - 21:39 EDT
This incident affected: Email Marketing, RSS feeds, Management Portal, and Forms and Landing Pages.