Click through errors
Incident Report for FeedBlitz
Postmortem

A database component failed and switching to a failover did not take place automatically as expected. We’re investigating why that happened in order to ensure the uptime that we all expect and have been used to historically.

Posted Apr 02, 2021 - 10:15 EDT

Resolved
Between 09:58am and 10:06am some visitors may have experienced issues clicking through from emails. The issue has now been resolved and click throughs should now work by retrying the relevant link
Posted Apr 02, 2021 - 10:00 EDT